summaryrefslogtreecommitdiff
path: root/app-admin/ansible/ansible-9.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-28 05:40:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-28 05:40:38 +0000
commit88f366f99d8e731ae1a13d9eca9a5284484d2c6f (patch)
tree07a82726de0e87969c85cdfb68522c4d444939e9 /app-admin/ansible/ansible-9.3.0.ebuild
parentfdd31f37b982d2c1b6d73b85f99718b13031be36 (diff)
gentoo auto-resync : 28:02:2024 - 05:40:38
Diffstat (limited to 'app-admin/ansible/ansible-9.3.0.ebuild')
-rw-r--r--app-admin/ansible/ansible-9.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-9.3.0.ebuild b/app-admin/ansible/ansible-9.3.0.ebuild
new file mode 100644
index 000000000000..51baea072b8f
--- /dev/null
+++ b/app-admin/ansible/ansible-9.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.16.0
+ <app-admin/ansible-core-2.17"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}