summaryrefslogtreecommitdiff
path: root/app-admin/ansible/ansible-7.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-17 04:08:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-17 04:08:35 +0100
commit43f85394ba834267589a4e6478ef419d40e22503 (patch)
treeb54082395e0e153c889b6dfe60d580a57992b3e8 /app-admin/ansible/ansible-7.5.0.ebuild
parentc4507bfdfd706b2b1301972490fe88ac3ddbc70e (diff)
gentoo auto-resync : 17:05:2023 - 04:08:35
Diffstat (limited to 'app-admin/ansible/ansible-7.5.0.ebuild')
-rw-r--r--app-admin/ansible/ansible-7.5.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-7.5.0.ebuild b/app-admin/ansible/ansible-7.5.0.ebuild
new file mode 100644
index 000000000000..0cefb7045e40
--- /dev/null
+++ b/app-admin/ansible/ansible-7.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.14.0
+ <app-admin/ansible-core-2.15"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}