summaryrefslogtreecommitdiff
path: root/app-admin/ansible-molecule
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-25 03:50:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-25 03:50:40 +0000
commit1e17db840dfd2f8b2b43a0a385c106812ebcfea9 (patch)
tree2c4c952ad148d645e2530f9c50315c4125f3517a /app-admin/ansible-molecule
parenta1c55a7e2f400a6170fd3df167bfdc299c05e2db (diff)
gentoo auto-resync : 25:02:2023 - 03:50:40
Diffstat (limited to 'app-admin/ansible-molecule')
-rw-r--r--app-admin/ansible-molecule/Manifest2
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index 1e57a0a2f546..255a0b1d08d7 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1,3 +1,5 @@
DIST ansible-molecule-4.0.1.tar.gz 301517 BLAKE2B 73cf7a2257368c737b9003236bf77011de167dd6f692166702e7948c136202b33bcce1c70893b61a95af9baa90e7b5266a5fa889e3bba0e5a8c9c1e6f48fec9a SHA512 7515e07bf791d5586e1f5fb4ce0d2f731c94c8268c589155340b2bdc1528534084870e66e492b2d883f9e9764293c93799a4c75478523502a2f37ad0642a472d
+DIST ansible-molecule-4.0.4.tar.gz 337260 BLAKE2B 14c493fa8aaa15466ebca19af9e5325ddb824c151d07d800136dcb714a430ea2dc42b38c9ec6e805e29ec3226376a532793d51c5d0544d6d5105510e5365ca8c SHA512 d7c1ceefbf74cbc27a397e7a40d855b23325bbde31a4cd1920961413a7db950e9fc530fec180de877eb37984bac8603033aa5a582e68e7f4c4ac2a10721c6630
EBUILD ansible-molecule-4.0.1.ebuild 2788 BLAKE2B e67f991ed869874d78b778091c0c4506feeda8ab4cb1c12c6185c454be478641f9c15c8cbf9ede832f8c625dbc290cfdde0f40a94d5585853953557b32ed84c8 SHA512 d71f3763148e9a4d85fc41bb1b13364c357f5169acbfe99e1277814f4fc535fdf8c3f9fdb2631ca395d4bce17c302e88d412ef14528f0396b6bf0715086e9d1e
+EBUILD ansible-molecule-4.0.4.ebuild 2789 BLAKE2B 6a6b545bd81fb53a4731874c4a6d55f6a0aa635d43077b3610a210a4ec48e8cb7ee6b1c7191dc34b10ab74c7d9983fd8790830291a99ba99afdebc986cf408d0 SHA512 0214fb65a7b851aa893bd51ed08e289cbf148dd682abdf610d5ddd86ccdb61ce746d8fe370c64f6898fb61e597b51421f76b07e730f27523876dd08683ccc8d7
MISC metadata.xml 407 BLAKE2B 869b6c1d6da66568eeac2daaca56567876dbfb057f50add7bbc95fef8a3fc38b99279d359a90573f8d6af47d0e451445827f6efeefa8fb0e7954e8b624783855 SHA512 e6dbbe2c0536ea84bdfea0168a743dbe3de424b442757441bc4f978e07d41ca6022eb2d6f269c921f42b4e7d858788f967c1c35bd4241a35dbe25a161f5744de
diff --git a/app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild b/app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild
new file mode 100644
index 000000000000..26d1841f8eab
--- /dev/null
+++ b/app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature
+
+MY_PN="${PN#ansible-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
+HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible-community/molecule/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="selinux"
+
+RDEPEND="$(python_gen_cond_dep '
+ >=dev-python/ansible-compat-2.2.0[${PYTHON_USEDEP}]
+ dev-python/cerberus[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/click-help-colors-0.9[${PYTHON_USEDEP}]
+ >=dev-python/enrich-1.2.7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.9.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/pluggy-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
+ >=dev-util/cookiecutter-1.7.3[${PYTHON_USEDEP}]
+ selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
+')"
+BDEPEND="$(python_gen_cond_dep '
+ >=dev-python/setuptools_scm-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.1[${PYTHON_USEDEP}]
+ doc? (
+ app-admin/ansible-core[${PYTHON_USEDEP}]
+ dev-python/ansible-pygments[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.17.2[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/ansi2html-1.6.0[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ <dev-python/pexpect-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-testinfra-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.1.0[${PYTHON_USEDEP}]
+ dev-util/yamllint
+ )
+')"
+
+S="${WORKDIR}"/${MY_P}
+
+# test_role.py doesn't play nicely with FEATURES=usersandbox. As for test_command.py:
+# - quite a few of these tests use the network;
+# - test_command_dependency[shell] only works if Molecule has previously been installed;
+# - tests involving creation of a new scenario fail on ansible-lint errors, even though
+# a config file is deployed which should skip expected issues.
+EPYTEST_DESELECT=(
+ src/molecule/test/functional/test_command.py
+ src/molecule/test/unit/command/init/test_role.py
+)
+
+distutils_enable_sphinx docs '>=dev-python/sphinx-notfound-page-0.7.1' '<dev-python/sphinx_ansible_theme-0.10.0'
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "Some optional packages commonly used in Molecule scenarios:"
+ optfeature "checking playbooks for practices and behaviour that can be improved" app-admin/ansible-lint
+}