summaryrefslogtreecommitdiff
path: root/app-admin/ansible-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 15:07:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 15:07:44 +0100
commitc9ac6938788ee1708e7c900f8f78e9037aea1ca1 (patch)
tree7775fcc8916726b2e7a58d7a251dee69292d231f /app-admin/ansible-lint
parent23fb10c075a74a6504647a16c3e06a6378e208c8 (diff)
gentoo auto-resync : 29:07:2022 - 15:07:44
Diffstat (limited to 'app-admin/ansible-lint')
-rw-r--r--app-admin/ansible-lint/Manifest2
-rw-r--r--app-admin/ansible-lint/ansible-lint-6.3.0.ebuild20
2 files changed, 12 insertions, 10 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 7adb00c8887a..dfeacf073cb6 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -4,5 +4,5 @@ DIST ansible-lint-6.2.2.tar.gz 232952 BLAKE2B 571dce6dc348c1158fed396fc29054421d
DIST ansible-lint-6.3.0.tar.gz 268331 BLAKE2B 00ea2dbc7bb5e71d63a737ac99d4116441f6b1eee2fa476d9aa4d78068064e53975df00950f337e7c9e25dacf8778ddd2e40eb5d3ea1301f56a80dfd90d42c20 SHA512 3e9d480cb90f3022a4b001c061c3e76b753620776a009b1563dce335c13ee38b7ac334725592ac644a2808d85ceb98b618a451c193bc7c4961474d4e7fbbb88e
EBUILD ansible-lint-5.4.0.ebuild 1852 BLAKE2B 913794c189a58ed0fa3cd0febde7b0ac4788294bee7b1309eb1d70f5619289d4c80f57a8227a7a834ce299c6a24a7c59285425c737d7b0cbd1e53c47ac570650 SHA512 5ca55f7c4d72b01d95813ecef1f3e984ff92993fb0cbf7e5090d938349dba942b88e695e6e34e022385c5a4d6e1fb457766d19aee606ceddedc458fa84c91bb4
EBUILD ansible-lint-6.2.2.ebuild 2443 BLAKE2B 65f93d1523c1cea6ceab40516c4b228881660718f4f7a4a2d98ffe205e7aa4e1b43d57ba6f081ff0d8e291889ba470f701e479fa24848eb0ad561fc85def2b5a SHA512 ddd4cfcf1940a27b3af62bd440e81c21c5fc7a6faaec5875398396bfc1dda54ee00023199e8d6f0e10f3c225a3d5ee26c5fd21edd1d59e3cb51e2342e8b8c1f5
-EBUILD ansible-lint-6.3.0.ebuild 2443 BLAKE2B b545898fa4aa33755f8741030b4b38cd6b9ab6b0bcee20f5625f8e6403a6c046d14b52882c1bdbc39c037bce6f48eb1cbd4a2c04f713a9b473254052ffe90f59 SHA512 78ae5e916712528aa349f3bd811f7302b2a364797e3eb8962f354d8d7420b0fdcf8d8a85f6477bfa9d8dd31c8f1addc0e3e736ff130245ae8fd7ea9abfb0c3aa
+EBUILD ansible-lint-6.3.0.ebuild 2579 BLAKE2B ec7b5653eed42701af8469791f48b7c3a82efa6a2fa5369aa89ca01e613a977b6ba2b5b4c9abaf825475a89360d4498c0408dca0573681309790a3a96195d73f SHA512 b975db3ada230a8a6b24e211b6aa5818bc1e99a9bdb0cdfa2672a05f65b9a8f8ba53c64107451c9acf63b895ae5be5b33eafc498ef90747a31bf92ef657a785c
MISC metadata.xml 561 BLAKE2B 0f55fc4da270c495c445e5afff0a8f7aaedd01abf3640f848cd9dc21e01fa7324c78846ee4bf917e4869b6c377fef61254a2288fa3d572c1bb77279571fb6631 SHA512 bd6bf6b916a0b736a0bfdd633f6569ce3124458169d77ef1cd86d6dda4099774088871560ce0106e11f139a2b48f13445e7a844e03a8669160c7e3fa44be5f36
diff --git a/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild b/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
index 6a378c69fa29..4aea510b329c 100644
--- a/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
+++ b/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
@@ -17,12 +17,6 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
-# Since 6.2.0 ansible-lint once again does not need access to Ansible Galaxy
-# even to get the test suite started, however quite a large fraction of tests
-# fails without network access. Needs more work.
-PROPERTIES="test_network"
-RESTRICT="test"
-
RDEPEND="
>=app-admin/ansible-base-2.12.0[${PYTHON_USEDEP}]
>=dev-python/ansible-compat-2.1.0[${PYTHON_USEDEP}]
@@ -47,18 +41,26 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.0.2_test-module-check.patch
)
-# Skip problematic tests (TODO: update this list for ansible-lint-6.2.0+):
+# Skip problematic tests:
# - test_call_from_outside_venv doesn't play nicely with the sandbox
-# - all test_eco and some test_prerun tests require Internet access
-# - as of 5.4.0, test_cli_auto_detect fails even when run manually with tox
+# - all the others require Internet access, mostly in order to access Ansible Galaxy
EPYTEST_DESELECT=(
+ test/test_cli_role_paths.py::test_run_playbook_github
test/test_eco.py
+ test/test_examples.py::test_custom_kinds
+ test/test_import_playbook.py::test_task_hook_import_playbook
+ test/test_list_rules.py::test_list_rules_includes_opt_in_rules
+ test/test_list_rules.py::test_list_rules_with_format_option
+ test/test_list_rules.py::test_list_tags_includes_opt_in_rules
test/test_main.py::test_call_from_outside_venv
test/test_prerun.py::test_install_collection
test/test_prerun.py::test_prerun_reqs_v1
test/test_prerun.py::test_prerun_reqs_v2
test/test_prerun.py::test_require_collection_wrong_version
+ test/test_rules_collection.py::test_rich_rule_listing
test/test_utils.py::test_cli_auto_detect
+ test/test_utils.py::test_template_lookup
+ test/test_verbosity.py::test_default_verbosity
)
distutils_enable_tests pytest