summaryrefslogtreecommitdiff
path: root/app-admin/ansible-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-22 00:06:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-22 00:06:25 +0100
commit236e75597883501f8700d9ba1a5c8276f578a17f (patch)
tree6b441a1dfa3a82840e3aa74678cc90c5294a4bca /app-admin/ansible-lint
parentbfd63d5b0e96ad32e0d0a8fe15512b6a9ac6fc9e (diff)
gentoo auto-resync : 22:05:2024 - 00:06:25HEADmaster
Diffstat (limited to 'app-admin/ansible-lint')
-rw-r--r--app-admin/ansible-lint/Manifest2
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.5.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 1bb1667ebfd8..a1a1400f6d90 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,5 +1,7 @@
DIST ansible-lint-24.2.0.tar.gz 513719 BLAKE2B 54e05acf982cf13cb2142a10bf04250171f07936df14933525dfae68b312a0d92ceb30867603dc7ce686206b7de010f6ca4eb9ab532ca000fc3c15c77c354c81 SHA512 3276d28c7b85a6087a0142cc56442efddf9ff3e81155455c74686015a2ab45ece64847b0243373ad01145e67599d8449866c122efe8ae404cd819011e41c5235
DIST ansible-lint-24.2.2.tar.gz 515822 BLAKE2B e9d8e689dfe4e4efbd4dad44ff3567f50412400ed979f2d60150f09f17c5f63f2441f25a33ecdf0112024ced07e62ac16b8a2dbc1c01d62855ec785fc75d1b9a SHA512 3de6b14e4b64ba577abcb67920a45dbf45fedb84e21091cd6a29e3c52a7a91555a152ee3e265624aafbf9dddba96d04241c2598a18f2103ce2cae48706142446
+DIST ansible_lint-24.5.0.tar.gz 525539 BLAKE2B 2681da05c69299f62b9a180ff4a10ea8fa27731d5a9f3d836e67fd211c2def86a6baa38583900e9c8be1a5da0a8658aded6e83cb8f13f129f55bd18a06b2e574 SHA512 b390743bbb09c03c9b402c35644c2b2e29b9a94fce842bf42b8938f7094b145ea75275f643949383bdad694408c606c0bc3038d5ca733a39ac08ef77cc7dc459
EBUILD ansible-lint-24.2.0.ebuild 1734 BLAKE2B cb94d883bce5f2d8bd26dc3ef73d3a742c4457cfcccf8dfa1c51c581af41e07269d914ea93c2a428ff66ac2b0f9ac77e89f8bab58f93eb959b94cbc476771566 SHA512 14c01aa109fbef294e21b29c92d7eef24a2fa54a549a266f562869bc74ca36c2221e211f1abe3382130d7308defef35b32a893e344cb2ea110b3eb59d7c6f43a
EBUILD ansible-lint-24.2.2.ebuild 1735 BLAKE2B 109574e3d7bc7b9a5619437428dc98a3aefd3d3014f86a01c637f04a7065d5ea889110045d3949edeb72dccbe1e2e817918de6842b378f500570234ef41e8b50 SHA512 009ec5d5d3dd434f103fe9e25ff1ef54f7cda08146260873cb42da04cecd0c7c0d20fc7f698414c92e621bcf24a4e244130ad2842429ba01a5760fe4abf1b1ca
+EBUILD ansible-lint-24.5.0.ebuild 1715 BLAKE2B 49d37fa20b54dec61007f84111719fc78dd51e5e9ef81aa332bd4174af908baa54dcf110aa6a9405cde14b27c08c6efb409d5d699d80ef97ad699dd821e1c41a SHA512 ea4507f8199354a0e2723123097224bde780d1bfa0df654ee3527ad4eec005d1d9a9d385c492441f5460a140de7bd02740a9fd422e364471e7029bf3044e4f88
MISC metadata.xml 449 BLAKE2B e6d058111e04c7c54f3fcbeedf38db0e257d07d95297bf6b330cbee8d6749516684c298bd3f36f81c6b399d1046cdc2e53090d1d713f0c9ed11ffda13ee86a16 SHA512 59b9d5d3c30f6cd3b0c4c7cb8f7e915ccecdd1993f96ff2f0978d7ddbee4d03ff69be63bdb55b6f8f614e2348811b131a146b08499200ec749b3bd1d47d3c7ee
diff --git a/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild b/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild
new file mode 100644
index 000000000000..fcaeec307b68
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.11[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}