summaryrefslogtreecommitdiff
path: root/app-admin/ansible-core/ansible-core-2.16.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-12 23:32:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-12 23:32:21 +0000
commit05644e4ce4886d97a712fcdca7d4144a7ced4191 (patch)
tree3954657c7c37c0621e63080b0e0530b9e1d8ad50 /app-admin/ansible-core/ansible-core-2.16.2.ebuild
parent3bcdaa6f06fae7659c3ac8294503c45e6736a2e1 (diff)
gentoo auto-resync : 12:12:2023 - 23:32:21
Diffstat (limited to 'app-admin/ansible-core/ansible-core-2.16.2.ebuild')
-rw-r--r--app-admin/ansible-core/ansible-core-2.16.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/ansible-core/ansible-core-2.16.2.ebuild b/app-admin/ansible-core/ansible-core-2.16.2.ebuild
new file mode 100644
index 000000000000..31aa6a3c7556
--- /dev/null
+++ b/app-admin/ansible-core/ansible-core-2.16.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
+ <dev-python/resolvelib-1.1.0[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+BDEPEND="
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}