summaryrefslogtreecommitdiff
path: root/app-admin/ansible-cmdb/ansible-cmdb-1.30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /app-admin/ansible-cmdb/ansible-cmdb-1.30.ebuild
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'app-admin/ansible-cmdb/ansible-cmdb-1.30.ebuild')
-rw-r--r--app-admin/ansible-cmdb/ansible-cmdb-1.30.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-admin/ansible-cmdb/ansible-cmdb-1.30.ebuild b/app-admin/ansible-cmdb/ansible-cmdb-1.30.ebuild
new file mode 100644
index 000000000000..c40d32a2b873
--- /dev/null
+++ b/app-admin/ansible-cmdb/ansible-cmdb-1.30.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ansible Configuration Management Database"
+HOMEPAGE="https://github.com/fboender/ansible-cmdb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/jsonxs[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"