summaryrefslogtreecommitdiff
path: root/app-accessibility/nfbtrans/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-accessibility/nfbtrans/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-accessibility/nfbtrans/files')
-rw-r--r--app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch11
-rw-r--r--app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch40
-rw-r--r--app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch24
3 files changed, 75 insertions, 0 deletions
diff --git a/app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch b/app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch
new file mode 100644
index 000000000000..7040de343db0
--- /dev/null
+++ b/app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch
@@ -0,0 +1,11 @@
+--- a/nfbtrans.c 2004-09-21 19:52:34.341784094 -0500
++++ b/nfbtrans.c 2004-09-21 19:54:07.005727168 -0500
+@@ -6,7 +6,7 @@
+ #define LINT_ARGS
+ #define DOS
+ #else
+-#define UNIX_PATH "/usr/local/lib/"
++#define UNIX_PATH "/etc/nfbtrans/"
+ #endif /* unix */
+ #include <stdio.h>
+ #include <sys/types.h>
diff --git a/app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch b/app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch
new file mode 100644
index 000000000000..14c13c063246
--- /dev/null
+++ b/app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch
@@ -0,0 +1,40 @@
+diff --git a/nfbtrans.c.orig b/nfbtrans.c
+index e697393..9a2944e 100644
+--- a/nfbtrans.c.orig
++++ b/nfbtrans.c
+@@ -534,7 +534,7 @@ void compact_line(char *);
+ void length_error(char *);
+ void do_lop_op(foptype *);
+ void do_lop(void);
+-void getline(void);
++void nfbtrans_getline(void);
+ void get_input(char *, int);
+ int get_paragraph_type(int);
+ void check_purge(void);
+@@ -2585,7 +2585,7 @@ void do_lop()
+ }
+ } /* do_lop */
+
+-void getline()
++void nfbtrans_getline()
+ {
+ int i = -1;
+ for (;;)
+@@ -2722,7 +2722,7 @@ int get_paragraph_type(int mode)
+ total_lines = 0;
+ do
+ {
+- getline();
++ nfbtrans_getline();
+ if (linein[0])
+ { /* line not empty */
+ if (prev_char == '\0')
+@@ -2874,7 +2874,7 @@ void get_word()
+ } /* head */
+ else
+ header_flag = 0;
+- getline();
++ nfbtrans_getline();
+ if (remove_page_nums)
+ remove_page_number();
+ if (auto_center)
diff --git a/app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch b/app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch
new file mode 100644
index 000000000000..61c991c8a368
--- /dev/null
+++ b/app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch
@@ -0,0 +1,24 @@
+--- a/Makefile 2017-06-13 11:08:23.428114301 -0500
++++ b/Makefile 2017-06-13 11:09:01.084376256 -0500
+@@ -28,10 +28,10 @@
+ djgppall: nfbtrans.exe
+
+ nfbtrans: $(OBJFILES)
+- $(CC) $(CFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
+
+ nfbtrans.exe:$(OBJFILES)
+- $(CC) $(CFLAGS) $(OBJFILES) -o nfbtrans.exe
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJFILES) -o nfbtrans.exe
+
+ ultrix:
+ $(MAKE) CFLAGS=-O
+@@ -44,7 +44,7 @@
+
+ insight:
+ insight -fno-builtin -fwritable-strings \
+- $(CFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
++ $(CFLAGS) $(LDFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
+
+ aix:
+ $(MAKE) all CC=cc CFLAGS="-o -Dunix -Daix"