summaryrefslogtreecommitdiff
path: root/app-accessibility/edbrowse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-accessibility/edbrowse
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-accessibility/edbrowse')
-rw-r--r--app-accessibility/edbrowse/Manifest4
-rw-r--r--app-accessibility/edbrowse/edbrowse-3.5.1.ebuild60
-rw-r--r--app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch22
-rw-r--r--app-accessibility/edbrowse/metadata.xml12
4 files changed, 98 insertions, 0 deletions
diff --git a/app-accessibility/edbrowse/Manifest b/app-accessibility/edbrowse/Manifest
new file mode 100644
index 000000000000..c4a9bee0500a
--- /dev/null
+++ b/app-accessibility/edbrowse/Manifest
@@ -0,0 +1,4 @@
+AUX edbrowse-3.5.1-implicit-decl.patch 777 BLAKE2B 1e619d2ee4ff1e0f1a7690d33d34b2669c59120aca50d8b9cc835a4dbc81ba20e19983d0fc4aa2dfa12a1281e85d489084b31b3dcf15bd684a8be78f819397d2 SHA512 f8fc77759b14480ddef08b8f893eaf6791cfcced347b2cc8d5356c8ae4e3ee381d5eb3685a8bef529cc4dae3bc615f6a5b47a35bf829c6a204553c6545acdcd8
+DIST edbrowse-3.5.1.zip 745277 BLAKE2B 2256faf58de68ab2d19d3137ddaaa92dbfdfff581d83c9f2b58e0e161c10aaa5c867dbf8b81da77f21abdd5c1a07d882abafff4bcfc0706fc33a73b7ba6bc087 SHA512 83bdb1d49afa04a41a84b71e86969880b518d8d6c1e448380d70710ad2373ed57cb3699d3ad50226ea4d5776f511ff50b9510655b27d26948213113699512fc2
+EBUILD edbrowse-3.5.1.ebuild 1420 BLAKE2B 9b41708d77b29db8bece8ec0bd74ca3166bf02551899289ab720de6bd5b57d85cd8538553777014862b66c52c18bde660b6fd606810624a9c76b661e3c906dcf SHA512 d1197dca946b138c64de82fb6e4e2ac6e2268d7d2d335ece41cb5ddafe7006ded0ee70bea1997234bd6bc67d15b5bbb6f7b90207c58034e9264d889cd4ffb28f
+MISC metadata.xml 394 BLAKE2B 6e65f68555af92f50c566ca53dffbb5c4a68bf96e7a6a895adf96be6518b83ce4cfe4a1b0fa6dcd7deabdb26afe67376743518154d18fa0c944d4538840e0b53 SHA512 76561a6366dca32455b5bff45b655fd155199b36a7a3243cb900e80382f64be642c64d6ee9095a0857484eaaca98fde8bd370b164d346d13d8744763d4b5e916
diff --git a/app-accessibility/edbrowse/edbrowse-3.5.1.ebuild b/app-accessibility/edbrowse/edbrowse-3.5.1.ebuild
new file mode 100644
index 000000000000..c8e5ad5fdf8b
--- /dev/null
+++ b/app-accessibility/edbrowse/edbrowse-3.5.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+inherit eutils
+
+DESCRIPTION="editor, browser, and mail client using the /bin/ed interface"
+HOMEPAGE="http://the-brannons.com/edbrowse/"
+SRC_URI="http://the-brannons.com/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl odbc l10n_fr"
+
+COMMON_DEPEND=">=dev-lang/spidermonkey-24.0:24
+ >=sys-libs/readline-6.0
+ >=net-misc/curl-7.36.0
+ >=dev-libs/libpcre-7.8
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ app-arch/unzip"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-implicit-decl.patch"
+}
+
+src_compile() {
+ jscppflags=$(pkg-config --cflags mozjs-24)
+ jslib=$(pkg-config --libs mozjs-24)
+ emake prefix=/usr JSLIB="${jslib}" JS_CXXFLAGS="${jscppflags}" STRIP=''
+ if use odbc; then
+ # Top-level makefile doesn't have this target.
+ cd src
+ emake prefix=/usr JSLIB="${jslib}" JS_CXXFLAGS="${jscppflags}" STRIP=''
+ cd ..
+ fi
+}
+
+src_install() {
+ cd src
+ emake prefix=/usr DESTDIR="${D}" install
+ if use odbc; then
+ dobin edbrowseodbc
+ fi
+ cd ..
+ dodoc CHANGES README todo
+ cd doc
+ dobin setup.ebrc
+ dohtml usersguide.html philosophy.html
+ dodoc sample.ebrc
+ if use l10n_fr; then
+ dohtml usersguide_fr.html philosophy_fr.html
+ dodoc sample_fr.ebrc
+ fi
+}
diff --git a/app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch b/app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch
new file mode 100644
index 000000000000..1880d2b3bfe0
--- /dev/null
+++ b/app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch
@@ -0,0 +1,22 @@
+diff -Naur edbrowse-3.5.1/src/fetchmail.c edbrowse-3.5.1.new/src/fetchmail.c
+--- edbrowse-3.5.1/src/fetchmail.c 2014-09-23 21:50:37.000000000 -0700
++++ edbrowse-3.5.1.new/src/fetchmail.c 2014-09-29 02:29:46.193856866 -0700
+@@ -6,6 +6,7 @@
+ * This file is part of the edbrowse project, released under GPL.
+ */
+
++#define _GNU_SOURCE
+ #include "eb.h"
+
+ #define MHLINE 200 /* length of a mail header line */
+diff -Naur edbrowse-3.5.1/src/sendmail.c edbrowse-3.5.1.new/src/sendmail.c
+--- edbrowse-3.5.1/src/sendmail.c 2014-09-23 21:50:37.000000000 -0700
++++ edbrowse-3.5.1.new/src/sendmail.c 2014-09-29 02:29:37.105874233 -0700
+@@ -5,6 +5,7 @@
+ * This file is part of the edbrowse project, released under GPL.
+ */
+
++#define _GNU_SOURCE
+ #include "eb.h"
+
+ #include <time.h>
diff --git a/app-accessibility/edbrowse/metadata.xml b/app-accessibility/edbrowse/metadata.xml
new file mode 100644
index 000000000000..53850bf1c4d0
--- /dev/null
+++ b/app-accessibility/edbrowse/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>accessibility@gentoo.org</email>
+ <name>Gentoo Accessibility Project</name>
+</maintainer>
+<longdescription>
+ edbrowse is a line editor, web browser and email client using the /bin/ed
+ user interface.
+</longdescription>
+</pkgmetadata>