summaryrefslogtreecommitdiff
path: root/xfce-base/xfce4-panel/xfce4-panel-4.12.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfce4-panel/xfce4-panel-4.12.0.ebuild')
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.12.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.12.0.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.12.0.ebuild
new file mode 100644
index 00000000..e2d2e44c
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.12.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Panel for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha ~amd64 arm hppa ia64 ~mips ppc ppc64 sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ >=x11-libs/cairo-1
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=x11-libs/libwnck-2.31:1
+ >=xfce-base/exo-0.10.3
+ >=xfce-base/garcon-0.4.0
+ >=xfce-base/libxfce4ui-4.12.0
+ >=xfce-base/libxfce4util-4.12.1
+ >=xfce-base/xfconf-4.12.0"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch -p1 "${FILESDIR}/increase_xfce_systray_spacing.patch"
+}
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS THANKS )
+}