summaryrefslogtreecommitdiff
path: root/xfce-base/libxfce4util/libxfce4util-4.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/libxfce4util/libxfce4util-4.12.1.ebuild')
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.12.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/libxfce4util-4.12.1.ebuild b/xfce-base/libxfce4util/libxfce4util-4.12.1.ebuild
new file mode 100644
index 00000000..b12a46fb
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.12.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}