summaryrefslogtreecommitdiff
path: root/x11-misc/qps/qps-1.10.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/qps/qps-1.10.18.ebuild')
-rw-r--r--x11-misc/qps/qps-1.10.18.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/qps/qps-1.10.18.ebuild b/x11-misc/qps/qps-1.10.18.ebuild
new file mode 100644
index 00000000..69867e59
--- /dev/null
+++ b/x11-misc/qps/qps-1.10.18.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils xdg-utils
+
+DESCRIPTION="Visual process manager - Qt version of ps/top"
+HOMEPAGE="https://lxqt.org/"
+SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1+ QPL-1.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ >=lxqt-base/lxqt-build-tools-0.5.0
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}