summaryrefslogtreecommitdiff
path: root/x11-misc/obconf-qt/obconf-qt-0.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/obconf-qt/obconf-qt-0.13.0.ebuild')
-rw-r--r--x11-misc/obconf-qt/obconf-qt-0.13.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/obconf-qt/obconf-qt-0.13.0.ebuild b/x11-misc/obconf-qt/obconf-qt-0.13.0.ebuild
new file mode 100644
index 00000000..b8437884
--- /dev/null
+++ b/x11-misc/obconf-qt/obconf-qt-0.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Openbox window manager configuration tool"
+HOMEPAGE="http://lxqt.org/"
+
+SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-wm/openbox:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}