summaryrefslogtreecommitdiff
path: root/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/liquid_feedback_core/liquid_feedback_core-2.2.3.ebuild')
-rw-r--r--www-apps/liquid_feedback_core/liquid_feedback_core-2.2.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.3.ebuild b/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.3.ebuild
new file mode 100644
index 00000000..7125d146
--- /dev/null
+++ b/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.3.ebuild,v 1.1 2013/04/28 12:47:03 tupone Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Internet platforms for proposition development and decision making"
+HOMEPAGE="http://www.public-software-group.org/liquid_feedback"
+SRC_URI="http://www.public-software-group.org/pub/projects/liquid_feedback/backend/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="HPND CC-BY-2.5"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-db/postgresql-base"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CPPFLAGS="-I $(pg_config --includedir)" \
+ LDFLAGS="${LDFLAGS} -L $(pg_config --libdir)" \
+ LDLIBS="-lpq $(pg_config --libs)"
+}
+
+src_install() {
+ dobin lf_update lf_update_suggestion_order lf_export
+ insinto /usr/share/${PN}
+ doins -r {core,init,demo,test}.sql update
+ dodoc README "${FILESDIR}"/postinstall-en.txt
+}