summaryrefslogtreecommitdiff
path: root/sys-kernel/tp_smapi-dkms/tp_smapi-dkms-0.44.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/tp_smapi-dkms/tp_smapi-dkms-0.44.ebuild')
-rw-r--r--sys-kernel/tp_smapi-dkms/tp_smapi-dkms-0.44.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-kernel/tp_smapi-dkms/tp_smapi-dkms-0.44.ebuild b/sys-kernel/tp_smapi-dkms/tp_smapi-dkms-0.44.ebuild
new file mode 100644
index 00000000..b97ec7e2
--- /dev/null
+++ b/sys-kernel/tp_smapi-dkms/tp_smapi-dkms-0.44.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+MY_PN=tp_smapi
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver sources"
+HOMEPAGE="https://github.com/linux-thinkpad/tp_smapi"
+SRC_URI="https://github.com/linux-thinkpad/tp_smapi/releases/download/tp-smapi/${PV}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="hdaps"
+
+DEPEND="sys-kernel/dkms"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use hdaps; then
+ local CONFIG_CHECK="~INPUT_UINPUT"
+ local WARNING_INPUT_UINPUT="Your kernel needs uinput for the hdaps module to perform better"
+ local CONFIG_CHECK="~!SENSORS_HDAPS"
+ local ERROR_SENSORS_HDAPS="${P} with USE=hdaps conflicts with in-kernel HDAPS (CONFIG_SENSORS_HDAPS)"
+ fi
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ if use hdaps; then
+ cp "${FILESDIR}"/dkms-hdaps.conf "${S}"/dkms.conf || die
+ else
+ cp "${FILESDIR}"/dkms.conf "${S}" || die
+ fi
+ dodir /usr/src/${P}
+ insinto /usr/src/${P}
+ doins -r "${S}"/*
+}
+
+pkg_postinst() {
+ dkms add ${PN}/${PV}
+}
+
+pkg_prerm() {
+ dkms remove ${PN}/${PV} --all
+}