summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-redcore/linux-redcore-4.9.25.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-redcore/linux-redcore-4.9.25.ebuild')
-rw-r--r--sys-kernel/linux-redcore/linux-redcore-4.9.25.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-kernel/linux-redcore/linux-redcore-4.9.25.ebuild b/sys-kernel/linux-redcore/linux-redcore-4.9.25.ebuild
new file mode 100644
index 00000000..151dcba3
--- /dev/null
+++ b/sys-kernel/linux-redcore/linux-redcore-4.9.25.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2004-2013 Sabayon Linux
+# Copyright 2015 Kogaion
+# Copyright 2016 Redcore Linux
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit versionator
+
+K_ROGKERNEL_SELF_TARBALL_NAME="redcore"
+K_REQUIRED_LINUX_FIRMWARE_VER="20161205"
+K_ROGKERNEL_FORCE_SUBLEVEL="25"
+K_ROGKERNEL_PATCH_UPSTREAM_TARBALL="0"
+
+_ver="$(get_version_component_range 1-2)"
+if use arm; then
+ K_KERNEL_IMAGE_NAME="uImage dtbs"
+elif [ "${_ver}" = "3.9" ]; then
+ K_ROGKERNEL_ZFS="1"
+fi
+K_KERNEL_NEW_VERSIONING="1"
+
+K_MKIMAGE_RAMDISK_ADDRESS="0x81000000"
+K_MKIMAGE_RAMDISK_ENTRYPOINT="0x00000000"
+K_MKIMAGE_KERNEL_ADDRESS="0x80008000"
+
+inherit redcore-kernel
+
+KEYWORDS="amd64 x86"
+DESCRIPTION="Official Redcore Linux Standard kernel image"
+RESTRICT="mirror"