summaryrefslogtreecommitdiff
path: root/sys-auth/polkit-qt5/polkit-qt5-0.113.0-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/polkit-qt5/polkit-qt5-0.113.0-r5.ebuild')
-rw-r--r--sys-auth/polkit-qt5/polkit-qt5-0.113.0-r5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-auth/polkit-qt5/polkit-qt5-0.113.0-r5.ebuild b/sys-auth/polkit-qt5/polkit-qt5-0.113.0-r5.ebuild
new file mode 100644
index 00000000..3e1c0fd1
--- /dev/null
+++ b/sys-auth/polkit-qt5/polkit-qt5-0.113.0-r5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="polkit-qt-1"
+inherit cmake kde.org
+
+DESCRIPTION="Qt wrapper around polkit-1 client libraries"
+HOMEPAGE="https://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${KDE_ORG_NAME}/${KDE_ORG_NAME}-${PV}.tar.xz"
+ KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
+ S="${WORKDIR}/${KDE_ORG_NAME}-${PV}"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=sys-auth/polkit-0.103
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README README.porting TODO )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF
+ )
+
+ cmake_src_configure
+}