summaryrefslogtreecommitdiff
path: root/net-wireless/horst/horst-3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/horst/horst-3.0.ebuild')
-rw-r--r--net-wireless/horst/horst-3.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-wireless/horst/horst-3.0.ebuild b/net-wireless/horst/horst-3.0.ebuild
new file mode 100644
index 00000000..6a990ab6
--- /dev/null
+++ b/net-wireless/horst/horst-3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Small 802.11 wireless LAN analyzer"
+HOMEPAGE="http://br1.einfach.org/tech/horst/"
+SRC_URI="http://br1.einfach.org/horst_dl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+pcap"
+
+DEPEND="sys-libs/ncurses
+ pcap? ( net-libs/libpcap )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if use pcap; then
+ emake PCAP=1
+ else
+ emake
+ fi
+}
+
+src_install() {
+ dosbin horst
+ dodoc ChangeLog README TODO
+}