summaryrefslogtreecommitdiff
path: root/net-misc/toxvpn/toxvpn-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/toxvpn/toxvpn-9999.ebuild')
-rw-r--r--net-misc/toxvpn/toxvpn-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/toxvpn/toxvpn-9999.ebuild b/net-misc/toxvpn/toxvpn-9999.ebuild
new file mode 100644
index 00000000..e87a4ab4
--- /dev/null
+++ b/net-misc/toxvpn/toxvpn-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils eutils git-2
+
+DESCRIPTION="toxvpn allows one to make tunneled point to point connections over Tox"
+HOMEPAGE="https://github.com/cleverca22/toxvpn"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/cleverca22/toxvpn.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-libs/jsoncpp
+ net-libs/tox"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ dobin "${WORKDIR}/${P}_build"/toxvpn
+}