summaryrefslogtreecommitdiff
path: root/net-misc/toxbot/toxbot-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/toxbot/toxbot-9999.ebuild')
-rw-r--r--net-misc/toxbot/toxbot-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/toxbot/toxbot-9999.ebuild b/net-misc/toxbot/toxbot-9999.ebuild
new file mode 100644
index 00000000..a6b52693
--- /dev/null
+++ b/net-misc/toxbot/toxbot-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils git-2 toolchain-funcs
+
+DESCRIPTION="Tox groupchats bot"
+HOMEPAGE="https://github.com/JFreegman/ToxBot"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/JFreegman/ToxBot.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="net-libs/tox[av]"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Verbose build
+ sed -i \
+ -e 's/@$(CC)/$(CC)/' \
+ Makefile || die
+ epatch_user
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ USER_CFLAGS="${CFLAGS}" \
+ USER_LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin "${S}/toxbot"
+}