summaryrefslogtreecommitdiff
path: root/net-libs/tox/tox-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/tox/tox-9999.ebuild')
-rw-r--r--net-libs/tox/tox-9999.ebuild41
1 files changed, 29 insertions, 12 deletions
diff --git a/net-libs/tox/tox-9999.ebuild b/net-libs/tox/tox-9999.ebuild
index 3b440eeb..fc7d1f40 100644
--- a/net-libs/tox/tox-9999.ebuild
+++ b/net-libs/tox/tox-9999.ebuild
@@ -1,23 +1,24 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-inherit autotools git-2
+inherit autotools eutils git-2 user systemd
-DESCRIPTION="Encrypted P2P, messenging, and audio/video calling platform"
-HOMEPAGE="https://tox.im"
+DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
+HOMEPAGE="https://tox.chat"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/irungentoo/toxcore"
+EGIT_REPO_URI="git://github.com/irungentoo/toxcore.git
+ https://github.com/irungentoo/toxcore.git"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="+av daemon logging log-debug log-error log-info log-warn ntox static-libs test"
+IUSE="+av daemon log log-debug log-error log-info log-trace log-warn ntox static-libs test"
RDEPEND="
- >=dev-libs/libsodium-1.0.0
+ >=dev-libs/libsodium-0.6.1[urandom,asm]
daemon? ( dev-libs/libconfig )
av? ( media-libs/libvpx
media-libs/opus )
@@ -30,12 +31,13 @@ pkg_setup() {
unset loglevel
if use log-info || use log-debug || use log-warn || use log-error ; then
- if use !logging ; then
+ if use !log ; then
ewarn "Logging disabled, but log level set,"
ewarn "it will have no effect."
else
- use log-info && loglevel=" INFO"
+ use log-trace && loglevel=" TRACE"
use log-debug && loglevel="${loglevel} DEBUG"
+ use log-info && loglevel="${loglevel} INFO"
use log-warn && loglevel="${loglevel} WARNING"
use log-error && loglevel="${loglevel} ERROR"
@@ -56,8 +58,8 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable logging) \
- $(usex logging "--with-logger-level=${loglevel##* }" "") \
+ $(use_enable log) \
+ $(usex log "--with-log-level=${loglevel##* }" "") \
$(use_enable av) \
$(use_enable test tests) \
$(use_enable ntox) \
@@ -68,6 +70,21 @@ src_configure() {
src_install() {
default
use daemon && { newinitd "${FILESDIR}"/initd tox-dht-daemon
- newconfd "${FILESDIR}"/confd tox-dht-daemon ; }
+ newconfd "${FILESDIR}"/confd tox-dht-daemon
+ insinto /etc
+ doins "${FILESDIR}"/tox-bootstrapd.conf
+ systemd_dounit "${FILESDIR}"/tox-bootstrapd.service ; }
prune_libtool_files
}
+
+pkg_postinst() {
+ use daemon && { enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+ ewarn "Backwards compatability with the bootstrap daemon"
+ ewarn "might have been broken a while ago."
+ ewarn "To resolve this issue, REMOVE the following files:"
+ ewarn "/var/lib/tox-dht-bootstrap/key"
+ ewarn "/etc/tox-bootstrapd.conf"
+ ewarn "/run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
+ ewarn "Then just re-emerge net-libs/tox" ; }
+}