summaryrefslogtreecommitdiff
path: root/media-gfx/lximage-qt/lximage-qt-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/lximage-qt/lximage-qt-0.7.0.ebuild')
-rw-r--r--media-gfx/lximage-qt/lximage-qt-0.7.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/lximage-qt/lximage-qt-0.7.0.ebuild b/media-gfx/lximage-qt/lximage-qt-0.7.0.ebuild
new file mode 100644
index 00000000..8bc08f4c
--- /dev/null
+++ b/media-gfx/lximage-qt/lximage-qt-0.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="LXImage Image Viewer - GPicView replacement"
+HOMEPAGE="http://lxqt.org/"
+
+SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/libexif
+ >=x11-libs/libfm-1.3.0:=
+ x11-libs/libfm-qt:=
+ x11-libs/libX11
+ x11-libs/libXfixes"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ lxqt-base/liblxqt
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPULL_TRANSLATIONS=OFF
+ )
+ cmake-utils_src_configure
+}