summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild')
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild
new file mode 100644
index 00000000..d3cd6668
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="http://lxqt.org/"
+
+SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
+KEYWORDS="amd64"
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/libqtxdg-3.2.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ ~lxqt-base/liblxqt-${PV}"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ !!lxqt-base/lxqt-common"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}