summaryrefslogtreecommitdiff
path: root/dev-qt/qthelp/qthelp-5.9.3-r1000.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qthelp/qthelp-5.9.3-r1000.ebuild')
-rw-r--r--dev-qt/qthelp/qthelp-5.9.3-r1000.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-qt/qthelp/qthelp-5.9.3-r1000.ebuild b/dev-qt/qthelp/qthelp-5.9.3-r1000.ebuild
new file mode 100644
index 00000000..5d62d649
--- /dev/null
+++ b/dev-qt/qthelp/qthelp-5.9.3-r1000.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qttools"
+inherit qt5-build-r10000
+
+DESCRIPTION="Qt5 module for integrating online documentation into applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="amd64"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtsql-${PV}[sqlite]
+ ~dev-qt/qtwidgets-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/help
+ src/assistant/qcollectiongenerator
+ src/assistant/qhelpconverter
+ src/assistant/qhelpgenerator
+)