summaryrefslogtreecommitdiff
path: root/dev-python/compizconfig-python/compizconfig-python-0.8.4-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/compizconfig-python/compizconfig-python-0.8.4-r5.ebuild')
-rw-r--r--dev-python/compizconfig-python/compizconfig-python-0.8.4-r5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/compizconfig-python/compizconfig-python-0.8.4-r5.ebuild b/dev-python/compizconfig-python/compizconfig-python-0.8.4-r5.ebuild
new file mode 100644
index 00000000..8defefd3
--- /dev/null
+++ b/dev-python/compizconfig-python/compizconfig-python-0.8.4-r5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/compizconfig-python/compizconfig-python-0.8.4-r5.ebuild,v 1.2 2013/08/25 14:58:39 pinkbyte Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_{6,7} )
+inherit eutils autotools-utils python-r1
+
+DESCRIPTION="Compizconfig Python Bindings"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.6
+ >=x11-libs/libcompizconfig-${PV}"
+
+DEPEND="${RDEPEND}
+ dev-python/pyrex[${PYTHON_USEDEP}]
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-fast-install
+ --disable-static
+ )
+ python_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl autotools-utils_src_compile
+}
+
+src_install() {
+ python_foreach_impl autotools-utils_src_install
+ prune_libtool_files --modules
+}