summaryrefslogtreecommitdiff
path: root/dev-ml/google-drive-ocamlfuse/google-drive-ocamlfuse-0.5.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/google-drive-ocamlfuse/google-drive-ocamlfuse-0.5.8.ebuild')
-rw-r--r--dev-ml/google-drive-ocamlfuse/google-drive-ocamlfuse-0.5.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/google-drive-ocamlfuse/google-drive-ocamlfuse-0.5.8.ebuild b/dev-ml/google-drive-ocamlfuse/google-drive-ocamlfuse-0.5.8.ebuild
new file mode 100644
index 00000000..87f838b9
--- /dev/null
+++ b/dev-ml/google-drive-ocamlfuse/google-drive-ocamlfuse-0.5.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit oasis
+
+OASIS_BUILD_DOCS=1
+DESCRIPTION="FUSE filesystem over Google Drive"
+HOMEPAGE="http://forge.ocamlcore.org/projects/gdfuse"
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-ml/ocurl-0.5.3:=
+ >=dev-ml/ocamlnet-3.3.5:=
+ >=dev-ml/cryptokit-1.3.14:=
+ >=dev-ml/extlib-1.5.1:=
+ >=dev-ml/yojson-1.0.2:=
+ >=dev-ml/xmlm-1.0.2:=
+ >=dev-ml/gapi-ocaml-0.2.5
+ dev-ml/ocamlfuse
+ dev-ml/ocaml-sqlite3"
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.0
+ >=dev-ml/pa_monad-6.0 )"
+DOCS=( "README.md" )