summaryrefslogtreecommitdiff
path: root/dev-ml/gapi-ocaml/gapi-ocaml-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/gapi-ocaml/gapi-ocaml-0.2.ebuild')
-rw-r--r--dev-ml/gapi-ocaml/gapi-ocaml-0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/gapi-ocaml/gapi-ocaml-0.2.ebuild b/dev-ml/gapi-ocaml/gapi-ocaml-0.2.ebuild
new file mode 100644
index 00000000..b4eb7b34
--- /dev/null
+++ b/dev-ml/gapi-ocaml/gapi-ocaml-0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit oasis
+
+OASIS_BUILD_DOCS=1
+DESCRIPTION="A simple OCaml client for Google Services"
+HOMEPAGE="http://gapi-ocaml.forge.ocamlcore.org/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1067/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-ml/ocurl-0.5.3:=
+ >=dev-ml/ocamlnet-3.3.5:=
+ >=dev-ml/cryptokit-1.3.14:=
+ >=dev-ml/extlib-1.5.1:=
+ >=dev-ml/yojson-1.0.2:=
+ >=dev-ml/xmlm-1.0.2:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.0
+ >=dev-ml/pa_monad-6.0 )"
+DOCS=( "README.md" )