summaryrefslogtreecommitdiff
path: root/dev-ml/camlpdf/camlpdf-1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlpdf/camlpdf-1.7.ebuild')
-rw-r--r--dev-ml/camlpdf/camlpdf-1.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/camlpdf/camlpdf-1.7.ebuild b/dev-ml/camlpdf/camlpdf-1.7.ebuild
new file mode 100644
index 00000000..35a260a0
--- /dev/null
+++ b/dev-ml/camlpdf/camlpdf-1.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="OCaml library for working with PDF files"
+HOMEPAGE="http://github.com/johnwhitington/camlpdf"
+SRC_URI="http://github.com/johnwhitington/camlpdf/archive/v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1
+ use doc && make doc
+}
+
+src_install() {
+ findlib_src_install
+}