summaryrefslogtreecommitdiff
path: root/app-text/qtspell/qtspell-0.8.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/qtspell/qtspell-0.8.2-r1.ebuild')
-rw-r--r--app-text/qtspell/qtspell-0.8.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-text/qtspell/qtspell-0.8.2-r1.ebuild b/app-text/qtspell/qtspell-0.8.2-r1.ebuild
new file mode 100644
index 00000000..3d63acc6
--- /dev/null
+++ b/app-text/qtspell/qtspell-0.8.2-r1.ebuild
@@ -0,0 +1,24 @@
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Spell checking for Qt text widgets"
+HOMEPAGE="https://github.com/manisandro/qtspell"
+SRC_URI="https://github.com/manisandro/${PN}/releases/download/${PV}/qtspell-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="qt5"
+
+DEPEND="app-text/enchant"
+
+src_unpack()
+{
+ unpack "${A}"
+ cd "${WORKDIR}"
+ mv qtspell-${PV} ${P}
+ if use qt5; then
+ cd "${S}"
+ sed -i "s/SET(USE_QT5 OFF/SET(USE_QT5 ON/" CMakeLists.txt
+ fi
+}