summaryrefslogtreecommitdiff
path: root/xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
commit7224c1253228e5c29c78cb3f0f26ce34770f2356 (patch)
tree1684924656132935256e034f35f92abee6623265 /xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild
Added ebuilds for kogaion desktop
Diffstat (limited to 'xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild')
-rw-r--r--xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild b/xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild
new file mode 100644
index 00000000..beeddfac
--- /dev/null
+++ b/xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils waf-utils gnome2-utils
+
+DESCRIPTION="Plugin for Thunar that adds context-menu items for Dropbox"
+HOMEPAGE="http://www.softwarebakery.com/maato/thunar-dropbox.html"
+SRC_URI="http://www.softwarebakery.com/maato/files/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-libs/glib:2
+ xfce-base/thunar
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ net-misc/dropbox
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-wscript.patch"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update /usr/share/icons/hicolor
+ gtk-update-icon-cache
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update /usr/share/icons/hicolor
+ gtk-update-icon-cache
+}