summaryrefslogtreecommitdiff
path: root/xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:45:00 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:45:00 +0200
commit5acba24490a47edca8a38013461675a41f442f53 (patch)
tree4f73470c6c762235c28bc0e55a1af6fa0436798f /xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild
parent5d65d52a7227128a8524fe1c9c0cf5ba5b10c2d1 (diff)
Added xfce base gentoo origin ebuilds. will split later if needed
Diffstat (limited to 'xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild')
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild
new file mode 100644
index 00000000..ccdb8934
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild,v 1.5 2014/01/28 14:17:23 ago Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug libcanberra libnotify +xklavier"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ media-libs/fontconfig
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/garcon-0.2
+ >=xfce-base/exo-0.8
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfconf-4.10
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ xklavier? ( >=x11-libs/libxklavier-5 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=x11-proto/inputproto-1.4
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable libnotify)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS TODO )
+}