summaryrefslogtreecommitdiff
path: root/xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:45:00 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:45:00 +0200
commit5acba24490a47edca8a38013461675a41f442f53 (patch)
tree4f73470c6c762235c28bc0e55a1af6fa0436798f /xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild
parent5d65d52a7227128a8524fe1c9c0cf5ba5b10c2d1 (diff)
Added xfce base gentoo origin ebuilds. will split later if needed
Diffstat (limited to 'xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild')
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild
new file mode 100644
index 00000000..3c0c0f7c
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild,v 1.10 2013/04/13 07:21:13 ago Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Panel for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ >=x11-libs/cairo-1
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=x11-libs/libwnck-2.31:1
+ >=xfce-base/exo-0.8
+ >=xfce-base/garcon-0.2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-icons.patch )
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS THANKS )
+}