summaryrefslogtreecommitdiff
path: root/x11-themes/kogaion-artwork-core/kogaion-artwork-core-2.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-10-26 12:33:35 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-10-26 12:33:35 +0200
commit687f45092b4f4ccf33765cee7427f054bae22344 (patch)
tree5cbf9b184110599c0af56484e7203a5c5e78ef76 /x11-themes/kogaion-artwork-core/kogaion-artwork-core-2.ebuild
parent79b2e36475ea3bcccb675a0b3c1bc356c4bb0dae (diff)
There`s no reason this shouldn`t be here
Diffstat (limited to 'x11-themes/kogaion-artwork-core/kogaion-artwork-core-2.ebuild')
-rw-r--r--x11-themes/kogaion-artwork-core/kogaion-artwork-core-2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-themes/kogaion-artwork-core/kogaion-artwork-core-2.ebuild b/x11-themes/kogaion-artwork-core/kogaion-artwork-core-2.ebuild
new file mode 100644
index 00000000..84e6c12e
--- /dev/null
+++ b/x11-themes/kogaion-artwork-core/kogaion-artwork-core-2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Sabayon Promotion
+# Copyright 2012 Rogentos Linux
+# Distributed under the terms of the GNU General Public License v2
+# Original Authors Sabayon Team
+# Maintainer BlackNoxis <stefan.cristian at rogentos.ro>
+
+EAPI=4
+inherit eutils mount-boot kogaion-artwork
+
+DESCRIPTION="Offical Kogaion Linux Core Artwork"
+HOMEPAGE="http://www.rogentos.ro"
+SRC_URI="http://pkg.rogentos.ro/~rogentos/distro/${CATEGORY}/${PN}/"${PN}"-${PV}.tar.gz"
+ # http://pkg2.rogentos.ro/~noxis/distro/${CATEGORY}/${PN}/${PN}-${PVR}.tar.gz Temporray suspended repo
+
+LICENSE="CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~arm ~x86 ~amd64"
+IUSE=""
+RDEPEND="sys-apps/findutils
+ !<sys-boot/grub-0.97-r22
+ !x11-themes/sabayon-artwork-core
+"
+
+S="${WORKDIR}/"
+
+src_install() {
+ # Fbsplash theme
+ insinto "${S}"/fbsplash
+ dodir /etc/splash/kogaion
+ insinto /etc/splash/kogaion/
+ doins -r "${S}"/fbsplash/kogaion/*
+
+ # Cursors
+ cd "${S}"/mouse/entis/cursors/
+ dodir /usr/share/cursors/xorg-x11/entis/cursors
+ insinto /usr/share/cursors/xorg-x11/entis/cursors/
+ doins -r ./
+
+ # Wallpaper
+ cd "${S}"/background
+ insinto /usr/share/backgrounds
+ doins *.png *.jpg
+ #newins rogentoslinux.png rogentos-nvidia.png
+
+ # Backdrop functionality for Xfce
+ dodir /usr/share/xfce4/backdrops
+ insinto /usr/share/xfce4/backdrops
+ doins *.png *.jpg
+}
+
+pkg_postinst() {
+ # mount boot first
+ mount-boot_mount_boot_partition
+
+ # Update Sabayon initramfs images
+ update_sabayon_kernel_initramfs_splash
+
+ einfo "Please report bugs or glitches to"
+ einfo "BlackNoxis"
+}