summaryrefslogtreecommitdiff
path: root/x11-terms/cool-retro-term/cool-retro-term-1.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:25:48 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:25:48 +0000
commit6e60337ebfcad35bc38e0e018b043ccc6eaa3482 (patch)
tree12fa380e54f3a5da1375ba0eb028fcf90cf3790c /x11-terms/cool-retro-term/cool-retro-term-1.1.1-r1.ebuild
parentc3eb3b968dd6f17f1e6c5ac61c8df2d56bdab413 (diff)
x11-terms/cool-retro-term : EAPI bump
Diffstat (limited to 'x11-terms/cool-retro-term/cool-retro-term-1.1.1-r1.ebuild')
-rw-r--r--x11-terms/cool-retro-term/cool-retro-term-1.1.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-terms/cool-retro-term/cool-retro-term-1.1.1-r1.ebuild b/x11-terms/cool-retro-term/cool-retro-term-1.1.1-r1.ebuild
new file mode 100644
index 00000000..32975d76
--- /dev/null
+++ b/x11-terms/cool-retro-term/cool-retro-term-1.1.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2016-2019 Redcore Linux Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils qmake-utils git-r3
+
+DESCRIPTION="A good looking terminal emulator which mimics the old cathode display"
+HOMEPAGE="https://github.com/Swordfish90/"
+LICENSE="GPL-2"
+
+EGIT_REPO_URI="${HOMEPAGE}${PN}.git"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5[localstorage]
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtwidgets:5
+ dev-qt/qtsvg:5
+"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ git-r3_fetch ${EGIT_REPO_URI} refs/tags/${PV} || die
+ git-r3_checkout || die
+}
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" ${PN}.pro || die
+}
+
+src_install() {
+ emake INSTALL_ROOT=${D} install || die
+}