summaryrefslogtreecommitdiff
path: root/sys-power/intel-thermald-1.2.01.ebuild
diff options
context:
space:
mode:
authorcrismblog <cristian@crismblog.ro>2015-02-24 10:13:47 +0200
committercrismblog <cristian@crismblog.ro>2015-02-24 10:13:47 +0200
commit21a45d8f5daa38fe5a26e6c2a425a32d71a65137 (patch)
tree0529d84aa745f0ae36fd44b08326985bf94a2f60 /sys-power/intel-thermald-1.2.01.ebuild
parentd699617b28b604526ed7e0ee7f47555b3c26ff1c (diff)
Add Intel Thermald
Diffstat (limited to 'sys-power/intel-thermald-1.2.01.ebuild')
-rw-r--r--sys-power/intel-thermald-1.2.01.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-power/intel-thermald-1.2.01.ebuild b/sys-power/intel-thermald-1.2.01.ebuild
new file mode 100644
index 00000000..6bb1a79a
--- /dev/null
+++ b/sys-power/intel-thermald-1.2.01.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit systemd autotools
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon"
+SRC_URI="https://github.com/01org/thermal_daemon/archive/v${PV}.tar.gz -> thermal_daemon-${PV}.tar.gz"
+
+LICENSE="GPL2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+S=${WORKDIR}/thermal_daemon-${PV}
+
+DEPEND="dev-libs/dbus-glib
+ dev-libs/libxml2"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-systemdsystemunitdir=$(systemd_get_unitdir)
+}
+
+src_install() {
+ default
+
+ dobin tools/thermald_set_pref.sh
+ doinitd "${FILESDIR}/thermald"
+}