summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-kogaion/linux-kogaion-4.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@rogentos.ro>2016-08-27 13:26:14 +0100
committerV3n3RiX <venerix@rogentos.ro>2016-08-27 13:26:14 +0100
commit31c81b5c5abdaa3e1c2b8e139bd69f418d7276da (patch)
tree2ac36af0cd3d899de2d2458695f4170de5e4005f /sys-kernel/linux-kogaion/linux-kogaion-4.4.5.ebuild
parentd9129d857fe3bcf022381713b4117d9a15208871 (diff)
bump kernel to 4.4.5, manifest will follow as soon as sources are up
Diffstat (limited to 'sys-kernel/linux-kogaion/linux-kogaion-4.4.5.ebuild')
-rw-r--r--sys-kernel/linux-kogaion/linux-kogaion-4.4.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-kernel/linux-kogaion/linux-kogaion-4.4.5.ebuild b/sys-kernel/linux-kogaion/linux-kogaion-4.4.5.ebuild
new file mode 100644
index 00000000..778b8414
--- /dev/null
+++ b/sys-kernel/linux-kogaion/linux-kogaion-4.4.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2004-2013 Sabayon Linux
+# Copyright 2015 Kogaion
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit versionator
+
+K_ROGKERNEL_SELF_TARBALL_NAME="kogaion"
+K_REQUIRED_LINUX_FIRMWARE_VER="20150206"
+K_ROGKERNEL_FORCE_SUBLEVEL="5"
+K_ROGKERNEL_PATCH_UPSTREAM_TARBALL="0"
+
+_ver="$(get_version_component_range 1-2)"
+if use arm; then
+ K_KERNEL_IMAGE_NAME="uImage dtbs"
+elif [ "${_ver}" = "3.9" ]; then
+ K_ROGKERNEL_ZFS="1"
+fi
+K_KERNEL_NEW_VERSIONING="1"
+
+K_MKIMAGE_RAMDISK_ADDRESS="0x81000000"
+K_MKIMAGE_RAMDISK_ENTRYPOINT="0x00000000"
+K_MKIMAGE_KERNEL_ADDRESS="0x80008000"
+
+inherit kogaion-kernel
+
+KEYWORDS="amd64 x86"
+DESCRIPTION="Official Kogaion Linux Standard kernel image"
+RESTRICT="mirror"