summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-kogaion/linux-kogaion-3.14.10.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-10-27 18:38:05 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-10-27 18:38:05 +0200
commit24934e623441310f644e5f72855b0f2bf9f3cd1a (patch)
treea453939bf58199bc2c3ff27bcf0accf2b221c6c4 /sys-kernel/linux-kogaion/linux-kogaion-3.14.10.ebuild
parent687f45092b4f4ccf33765cee7427f054bae22344 (diff)
Incoming! Moving Rogento.git to kogaion-desktop. Finally
Diffstat (limited to 'sys-kernel/linux-kogaion/linux-kogaion-3.14.10.ebuild')
-rw-r--r--sys-kernel/linux-kogaion/linux-kogaion-3.14.10.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-kernel/linux-kogaion/linux-kogaion-3.14.10.ebuild b/sys-kernel/linux-kogaion/linux-kogaion-3.14.10.ebuild
new file mode 100644
index 00000000..423b3325
--- /dev/null
+++ b/sys-kernel/linux-kogaion/linux-kogaion-3.14.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2004-2013 Sabayon Linux
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit versionator
+
+K_ROGKERNEL_SELF_TARBALL_NAME="kogaion"
+K_REQUIRED_LINUX_FIRMWARE_VER="20130728"
+K_ROGKERNEL_FORCE_SUBLEVEL="0"
+K_ROGKERNEL_PATCH_UPSTREAM_TARBALL="0"
+
+_ver="$(get_version_component_range 1-2)"
+if use arm; then
+ K_KERNEL_IMAGE_NAME="uImage dtbs"
+elif [ "${_ver}" = "3.9" ]; then
+ K_ROGKERNEL_ZFS="1"
+fi
+K_KERNEL_NEW_VERSIONING="1"
+
+K_MKIMAGE_RAMDISK_ADDRESS="0x81000000"
+K_MKIMAGE_RAMDISK_ENTRYPOINT="0x00000000"
+K_MKIMAGE_KERNEL_ADDRESS="0x80008000"
+
+inherit kogaion-kernel
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="Official Kogaion Linux Standard kernel image"
+RESTRICT="mirror"