summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-headers/linux-headers-4.16.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-12 03:15:50 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-12 03:15:50 +0100
commit05dd9a296958364794a0b4910bf9623f51b083f9 (patch)
tree448e3c1f8e93ed9301b99124da2636fca71a968b /sys-kernel/linux-headers/linux-headers-4.16.1.ebuild
parent120066f9e16553b0569c6a94336b6b688e7a91c1 (diff)
- Workaround amdgpu and radeon issues by adding a new swiotlb option.
defaults to disabled ( old way ) while still possible to enable and test the new way / code. The newer code does not work good or does not work at all on some HW ( mine as example ) see: https://lkml.org/lkml/2018/4/5/737 https://bugzilla.kernel.org/show_bug.cgi?id=198511 https://bugs.freedesktop.org/show_bug.cgi?id=105038
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-4.16.1.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-4.16.1.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-4.16.1.ebuild b/sys-kernel/linux-headers/linux-headers-4.16.1.ebuild
deleted file mode 100644
index 9aaf8db0..00000000
--- a/sys-kernel/linux-headers/linux-headers-4.16.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils
-
-EXTRAVERSION="redcore"
-KV_FULL="${PV}-${EXTRAVERSION}"
-
-DESCRIPTION="Official Redcore Linux Kernel Sources"
-HOMEPAGE="https://redcorelinux.org"
-SRC_URI="https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-${PV}.tar.xz"
-
-KEYWORDS="~amd64"
-LICENSE="GPL-2"
-SLOT="${PV}"
-IUSE=""
-
-RESTRICT="strip mirror"
-DEPEND="
- app-arch/xz-utils
- sys-devel/autoconf
- sys-devel/bc
- sys-devel/make"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/enable_alx_wol.patch
- "${FILESDIR}"/0001-Revert-ath10k-activate-user-space-firmware-loading-a.patch
- "${FILESDIR}"/0001-Revert-swiotlb-remove-various-exports.patch
- "${FILESDIR}"/0001-Revert-x86-ACPI-cstate-Allow-ACPI-C1-FFH-MWAIT-use-o.patch
- "${FILESDIR}"/mute-pps_state_mismatch.patch
- "${FILESDIR}"/drop_ancient-and-wrong-msg.patch
- "${FILESDIR}"/nouveau-pascal-backlight.patch
- "${FILESDIR}"/linux-hardened.patch
- "${FILESDIR}"/uksm-for-linux-hardened.patch )
-
-S="${WORKDIR}"/linux-"${PV}"
-
-pkg_setup() {
- export REAL_ARCH="$ARCH"
- unset ARCH ; unset LDFLAGS #will interfere with Makefile if set
-}
-
-src_prepare() {
- default
- emake mrproper
- sed -ri "s|^(EXTRAVERSION =).*|\1 -${EXTRAVERSION}|" Makefile
- cp "${FILESDIR}"/"${EXTRAVERSION}"-amd64.config .config
-}
-
-src_compile() {
- emake prepare modules_prepare
-}
-
-src_install() {
- dodir usr/src/linux-"${KV_FULL}"
- cp -ax "${S}"/* "${D}"usr/src/linux-"${KV_FULL}"
-}
-
-_kernel_sources_delete() {
- rm -rf "${ROOT}"usr/src/linux-"${KV_FULL}"
-}
-
-pkg_postrm() {
- _kernel_sources_delete
-}