summaryrefslogtreecommitdiff
path: root/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-13 12:30:18 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-13 12:30:18 +0000
commita47be25ce291efd782bf2fda417d95eb705c4a72 (patch)
tree257f0092ad80ca4afda9c7fea031d50575425681 /sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r2.ebuild
parent29f1bd96807023d399b4902991b6a3b5f47d387d (diff)
sys-kernel/dracut-config-redcore : make sure we have vboxvideo/qxl inside initramfs
Diffstat (limited to 'sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r2.ebuild')
-rw-r--r--sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r2.ebuild b/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r2.ebuild
new file mode 100644
index 00000000..cc283833
--- /dev/null
+++ b/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Redcore Linux Dracut configuration files"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-kernel/dracut"
+
+S="${FILESDIR}"
+
+src_install() {
+ dodir "etc/dracut.conf.d" || die
+ insinto "etc/dracut.conf.d" || die
+ newins redcore-dracut.conf redcore-dracut.conf.example || die
+}
+
+pkg_preinst() {
+ if [[ -f ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf" ]]; then
+ mv ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf" ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf.bak"
+ fi
+}
+
+pkg_postinst() {
+ if [[ -f ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf.bak" ]]; then
+ mv ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf.bak" ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf"
+ fi
+}