summaryrefslogtreecommitdiff
path: root/sys-fs/spl-utils/spl-utils-0.7.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-27 14:30:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-27 14:30:35 +0100
commitcfb4ebb141e5f5625c4ec9a42e8a84e7ebda1104 (patch)
tree84f23615eab896b6d473589b99f7f1100bdc2405 /sys-fs/spl-utils/spl-utils-0.7.9.ebuild
parent86dc0f17c1c68e91d62ac309d107694860cbb711 (diff)
sys-fs/{spl,zfs} : kernel 4.18 compat
Diffstat (limited to 'sys-fs/spl-utils/spl-utils-0.7.9.ebuild')
-rw-r--r--sys-fs/spl-utils/spl-utils-0.7.9.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/sys-fs/spl-utils/spl-utils-0.7.9.ebuild b/sys-fs/spl-utils/spl-utils-0.7.9.ebuild
deleted file mode 100644
index 02a1ed1b..00000000
--- a/sys-fs/spl-utils/spl-utils-0.7.9.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-inherit flag-o-matic autotools-utils
-
-MY_PN="spl"
-MY_P="${MY_PN}-${PV}"
-
-SRC_URI="https://github.com/zfsonlinux/zfs/releases/download/zfs-${PV}/${MY_P}.tar.gz"
-
-DESCRIPTION="The Solaris Porting Layer is a Linux kernel module which provides many of the Solaris kernel APIs"
-HOMEPAGE="http://zfsonlinux.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="debug"
-
-RESTRICT="debug? ( strip ) test"
-
-S="${WORKDIR}/${MY_P}"
-
-COMMON_DEPEND="dev-lang/perl
- virtual/awk"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}
- !sys-devel/spl"
-
-AT_M4DIR="config"
-AUTOTOOLS_IN_SOURCE_BUILD="1"
-
-DOCS=( AUTHORS DISCLAIMER )
-
-src_prepare() {
- # Workaround for hard coded path
- sed -i "s|/sbin/lsmod|/bin/lsmod|" "${S}/scripts/check.sh" || \
- die "Cannot patch check.sh"
-
- # splat is unnecessary unless we are debugging
- use debug || { sed -e 's/^subdir-m += splat$//' -i "${S}/module/Makefile.in" || die ; }
-
- # Set module revision number
- [ ${PV} != "9999" ] && \
- { sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-redcore/" "${S}/META" || die "Could not set Redcore release"; }
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- filter-ldflags -Wl,*
-
- local myeconfargs=(
- --bindir="${EPREFIX}/bin"
- --sbindir="${EPREFIX}/sbin"
- --with-config=user
- $(use_enable debug)
- )
- autotools-utils_src_configure
-}