summaryrefslogtreecommitdiff
path: root/sys-boot/etcher/etcher-1.18.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-19 10:42:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-19 10:42:25 +0100
commit3e59d1a1b671304c2d2efea8f7c97695da595387 (patch)
treeb4e44d3daf3aad9b90feee29dd299ca59e022fcd /sys-boot/etcher/etcher-1.18.4-r2.ebuild
parente992ee38bfe1c2af476a204f9c531c8fb231bd59 (diff)
sys-boot/etcher : EAPI bump
Diffstat (limited to 'sys-boot/etcher/etcher-1.18.4-r2.ebuild')
-rw-r--r--sys-boot/etcher/etcher-1.18.4-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-boot/etcher/etcher-1.18.4-r2.ebuild b/sys-boot/etcher/etcher-1.18.4-r2.ebuild
new file mode 100644
index 00000000..eda797cd
--- /dev/null
+++ b/sys-boot/etcher/etcher-1.18.4-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=8
+
+MY_PN="balenaEtcher"
+
+inherit desktop xdg-utils
+
+DESCRIPTION="Flash OS images to SD cards & USB drives, safely and easily."
+HOMEPAGE="https://etcher.io/"
+SRC_URI="https://github.com/balena-io/${PN}/releases/download/v${PV}/${MY_PN}-${PV}-x64.AppImage"
+
+LICENSE="GPL2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/nss
+ media-libs/alsa-lib
+ sys-apps/lsb-release
+ x11-libs/gtk+:2
+ x11-libs/libXtst
+ x11-libs/libnotify"
+RDEPEND="${DEPEND}"
+
+RESTRICT="mirror strip"
+
+S="${DISTDIR}"
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ newbin ${MY_PN}-${PV}-x64.AppImage ${MY_PN}
+ domenu ${FILESDIR}/${MY_PN}.desktop
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
+