summaryrefslogtreecommitdiff
path: root/sys-apps/snap-confine/snap-confine-1.0.43.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@rogentos.ro>2016-11-12 17:36:57 +0000
committerV3n3RiX <venerix@rogentos.ro>2016-11-12 17:36:57 +0000
commit925e837119e2d523797e821cd6f850d2088da79a (patch)
tree601fa55abf6c459a2fd878e5d4691c5a52ca541b /sys-apps/snap-confine/snap-confine-1.0.43.ebuild
parent0f8199d50a84cb9ed4c96db81a22a93c49ae61cf (diff)
add snapcraft
Diffstat (limited to 'sys-apps/snap-confine/snap-confine-1.0.43.ebuild')
-rw-r--r--sys-apps/snap-confine/snap-confine-1.0.43.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/snap-confine/snap-confine-1.0.43.ebuild b/sys-apps/snap-confine/snap-confine-1.0.43.ebuild
new file mode 100644
index 00000000..4bec088d
--- /dev/null
+++ b/sys-apps/snap-confine/snap-confine-1.0.43.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="The snap-confine program helps to launch snappy applications"
+HOMEPAGE="http://snapcraft.io/"
+SRC_URI="https://github.com/snapcore/${PN}/releases/download/${PV}/${P}.tar.gz"
+RESTRICT="mirror"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+
+DEPEND="dev-python/docutils
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/gcc
+ sys-devel/make
+ virtual/libudev"
+
+src_configure() {
+ econf --disable-apparmor
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README.md PORTING
+}