summaryrefslogtreecommitdiff
path: root/net-im/qtox/qtox-9999.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2015-08-24 20:47:16 +0300
committerBlackNoxis <steven.darklight@gmail.com>2015-08-24 20:47:16 +0300
commit0c6710a5661dcb9d197d5dc6c5f22aeb03ba583d (patch)
tree2792107df1e29aa284f37a4302b05eed7689b6ed /net-im/qtox/qtox-9999.ebuild
parent3a33f2966f834d3520b03df59018e3d0295fcc69 (diff)
Revert "[toxcore] adaugat toxcore"
This reverts commit 3a33f2966f834d3520b03df59018e3d0295fcc69.
Diffstat (limited to 'net-im/qtox/qtox-9999.ebuild')
-rw-r--r--net-im/qtox/qtox-9999.ebuild39
1 files changed, 10 insertions, 29 deletions
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index 1df981a5..0fc8ffaf 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -14,39 +14,26 @@ EGIT_REPO_URI="git://github.com/tux3/qtox.git"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="+filter_audio gtk X"
+IUSE=""
DEPEND="
- dev-qt/linguist-tools:5
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
- dev-qt/qtgui:5[gif,jpeg,png,xcb]
+ dev-qt/qtgui:5[gif,jpeg,png]
dev-qt/qtnetwork:5
dev-qt/qtopengl:5
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
dev-qt/qtxml:5
- filter_audio? ( media-libs/libfilteraudio )
- media-gfx/qrencode
media-libs/openal
- >=media-video/ffmpeg-2.6.3[webp,v4l]
- gtk? ( dev-libs/atk
- dev-libs/glib:2
- x11-libs/gdk-pixbuf[X]
- x11-libs/gtk+:2
- x11-libs/cairo[X]
- x11-libs/pango[X] )
- net-libs/tox[av]
- X? ( x11-libs/libX11
- x11-libs/libXScrnSaver )"
+ media-libs/opencv[-qt4,v4l]
+ net-libs/tox[av]"
RDEPEND="${DEPEND}"
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
if [[ $(tc-getCXX) == *g++ ]] ; then
if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 8 || $(gcc-major-version) -lt 4 ]] ; then
- eerror "You need at least sys-devel/gcc-4.8.3"
- die "You need at least sys-devel/gcc-4.8.3"
+ eerror "You need at least sys-devel/gcc-4.8.0"
+ die "You need at least sys-devel/gcc-4.8.0"
fi
fi
fi
@@ -57,17 +44,11 @@ src_prepare() {
}
src_configure() {
- use filter_audio || NO_FILTER_AUDIO="DISABLE_FILTER_AUDIO=YES"
- use gtk || NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
- use X || NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
- eqmake5 \
- ${NO_FILTER_AUDIO} \
- ${NO_GTK_SUPPORT} \
- ${NO_X_SUPPORT}
+ eqmake5
}
src_install() {
dobin "${S}/qtox"
- doicon -s scalable "${S}/img/icons/qtox.svg"
- domenu "${S}/qTox.desktop"
+ doicon -s scalable "${FILESDIR}"/tox.svg
+ make_desktop_entry "qtox" "qTox" "/usr/share/icons/hicolor/scalable/apps/tox.svg" "Network"
}