summaryrefslogtreecommitdiff
path: root/media-tv/sopcast/sopcast-3.2.6-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-18 11:00:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-18 11:00:54 +0100
commit206cdbe3ce1d028ad0da284dd3ddc1de01ba6cb1 (patch)
treec5aa7e0e86c3b8c199f54d34e18a531161f0cc38 /media-tv/sopcast/sopcast-3.2.6-r5.ebuild
parentccb564b4f48ad9d91ddd04719826fafb8c02306e (diff)
media-tv/sopcast : EAPI bump
Diffstat (limited to 'media-tv/sopcast/sopcast-3.2.6-r5.ebuild')
-rw-r--r--media-tv/sopcast/sopcast-3.2.6-r5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-tv/sopcast/sopcast-3.2.6-r5.ebuild b/media-tv/sopcast/sopcast-3.2.6-r5.ebuild
new file mode 100644
index 00000000..5bbbb742
--- /dev/null
+++ b/media-tv/sopcast/sopcast-3.2.6-r5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=8
+
+MY_PN="sp-auth"
+
+DESCRIPTION="SopCast free P2P Internet TV binary"
+LICENSE="SopCast-unknown-license"
+HOMEPAGE="http://www.sopcast.com/"
+SRC_URI="http://download.sopcast.com/download/${MY_PN}.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+# All dependencies might not be listed, since the binary blob's homepage only lists libstdc++
+RDEPEND="amd64? ( sys-libs/libstdc++-v3[multilib] )
+ x86? ( >=virtual/libstdc++-3.3 )"
+
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_PN}
+
+src_install() {
+ exeinto usr/bin/
+ doexe sp-sc-auth || die "doexe failed"
+ dodoc Readme || die "dodoc failed"
+}