summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.12.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-22 12:41:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-22 12:41:06 +0100
commit48e366bb85c6037f3c6c199e20ee8e9afcbc7a18 (patch)
treeb0f1d9f66c3a4ff6839acef3b085d2ba906c9815 /lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.12.0-r1.ebuild
parent719d78a9a2b54a93db561e02702df159373a1f86 (diff)
lxqt-base/lxqt-meta : revision bump
Diffstat (limited to 'lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.12.0-r1.ebuild')
-rw-r--r--lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.12.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.12.0-r1.ebuild b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.12.0-r1.ebuild
new file mode 100644
index 00000000..e7269a49
--- /dev/null
+++ b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.12.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Daemon and library for global keyboard shortcuts registration"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ >=dev-libs/libqtxdg-3.1.0
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ !lxqt-base/lxqt-common
+"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}