summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-22 11:08:08 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-22 11:08:08 +0100
commit16542d337461ff38a6ccfa99c05d2535bdeeebc4 (patch)
treefd957ea1102b47dbbb23008fd1cb7e1036aec1a0 /lxqt-base/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild
parentb6033548fb17c02218d9fa0a398f1ce94cf5ece5 (diff)
lxqt-base/lxqt-build-tools : version bump
Diffstat (limited to 'lxqt-base/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild')
-rw-r--r--lxqt-base/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild b/lxqt-base/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild
new file mode 100644
index 00000000..6cc4c57a
--- /dev/null
+++ b/lxqt-base/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Various packaging tools and scripts for LXQt applications"
+HOMEPAGE="http://lxqt.org/"
+
+SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
+KEYWORDS="amd64"
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.50.0
+ dev-qt/qtcore:5"
+DEPEND="${RDEPEND}
+ >=dev-libs/libqtxdg-3.2.0
+ dev-qt/linguist-tools:5"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}