summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-build-tools/lxqt-build-tools-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-22 11:38:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-22 11:38:43 +0100
commit8e16e0506459434711747ff1070117f28d7600c3 (patch)
treedf48c4e2d077852133f7c14c9b87ca4cbeb358d6 /lxqt-base/lxqt-build-tools/lxqt-build-tools-0.4.0.ebuild
parentceacb6948a2e9aa867c5179f09e0fc699695e992 (diff)
lxqt-base/lxqt-build-tools : port missing pieces
Diffstat (limited to 'lxqt-base/lxqt-build-tools/lxqt-build-tools-0.4.0.ebuild')
-rw-r--r--lxqt-base/lxqt-build-tools/lxqt-build-tools-0.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-build-tools/lxqt-build-tools-0.4.0.ebuild b/lxqt-base/lxqt-build-tools/lxqt-build-tools-0.4.0.ebuild
new file mode 100644
index 00000000..7ef58c36
--- /dev/null
+++ b/lxqt-base/lxqt-build-tools/lxqt-build-tools-0.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Common base library for the LXQt desktop environment"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="dev-qt/linguist-tools:5"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}