summaryrefslogtreecommitdiff
path: root/lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 15:06:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 15:06:39 +0000
commit854ab0c30e52f7498c2487ebc6aa00363badf659 (patch)
tree216290ed1a0cce0ec52d4e108bd35313ca934608 /lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild
parentff4de87a5b85bc3e088057c8d7a96a2216dc8eeb (diff)
do some cleaning, update README
Diffstat (limited to 'lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild')
-rw-r--r--lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild b/lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild
new file mode 100644
index 00000000..612b0af7
--- /dev/null
+++ b/lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="LXDE GTK+ theme switcher"
+HOMEPAGE="http://lxde.sourceforge.net"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~mips ppc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="dbus"
+
+RDEPEND="x11-libs/gtk+:2
+ dbus? ( dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/"${PN}"-desktop.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable dbus)
+}