summaryrefslogtreecommitdiff
path: root/dev-qt/qt5ct/qt5ct-0.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@rogentos.ro>2016-07-15 19:37:15 +0100
committerV3n3RiX <venerix@rogentos.ro>2016-07-15 19:37:15 +0100
commit7c8902e9ae243669ed4e7e5828f9f0fbee75ae1b (patch)
treef3cd55c7c56f3f90af5e74175c1ec47ae2b815a8 /dev-qt/qt5ct/qt5ct-0.24.ebuild
parent48ed061e72d23131832814eb7cfb4bc2387630f2 (diff)
add QT5 configuration tool, since it's now default QT implementation in Kogaion
Diffstat (limited to 'dev-qt/qt5ct/qt5ct-0.24.ebuild')
-rw-r--r--dev-qt/qt5ct/qt5ct-0.24.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-qt/qt5ct/qt5ct-0.24.ebuild b/dev-qt/qt5ct/qt5ct-0.24.ebuild
new file mode 100644
index 00000000..be9cf289
--- /dev/null
+++ b/dev-qt/qt5ct/qt5ct-0.24.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils qmake-utils
+
+DESCRIPTION="Qt5 Configuration Tool"
+HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/linguist-tools-5.4.0:5
+ >=dev-qt/qtcore-5.4.0:5
+ >=dev-qt/qtsvg-5.4.0:5
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/"${P}"
+
+src_configure(){
+ local myeqmakeargs=(
+ ${PN}.pro
+ PREFIX="${EPREFIX}/usr"
+ DESKTOPDIR="${EPREFIX}/usr/share/applications"
+ ICONDIR="${EPREFIX}/usr/share/pixmaps"
+ )
+ eqmake5 ${myeqmakeargs[@]}
+}
+
+src_install(){
+ emake INSTALL_ROOT="${ED}" install || die
+}
+
+pkg_postinst(){
+ elog "After install this package, please, add the following"
+ elog "line into the ~/.xprofile (user) or /etc/environment (system):"
+ elog "export QT_QPA_PLATFORMTHEME=qt5ct"
+ elog "and it will work."
+}