summaryrefslogtreecommitdiff
path: root/dev-python/meteo-qt/meteo-qt-0.9.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 23:39:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 23:39:31 +0100
commit32426ea820fe85f4529ca7dcc1f3939536bb8045 (patch)
treea00fde1ddfd54539713a58284ee96d3974115cd7 /dev-python/meteo-qt/meteo-qt-0.9.9.ebuild
parentda0fc0f6b234444a81fdf039139463ded7e863af (diff)
dev-python/meteo-qt : version bump
Diffstat (limited to 'dev-python/meteo-qt/meteo-qt-0.9.9.ebuild')
-rw-r--r--dev-python/meteo-qt/meteo-qt-0.9.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/meteo-qt/meteo-qt-0.9.9.ebuild b/dev-python/meteo-qt/meteo-qt-0.9.9.ebuild
new file mode 100644
index 00000000..0123b6d0
--- /dev/null
+++ b/dev-python/meteo-qt/meteo-qt-0.9.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="System tray application for weather status information"
+HOMEPAGE="https://github.com/dglent/meteo-qt"
+SRC_URI="https://github.com/dglent/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}